Hellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 1 day agoTIFU by not using objects in my object-oriented programming courseworklemmy.caexternal-linkmessage-square21fedilinkarrow-up172arrow-down19cross-posted to: programmer_humor@programming.dev
arrow-up163arrow-down1external-linkTIFU by not using objects in my object-oriented programming courseworklemmy.caHellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 1 day agomessage-square21fedilinkcross-posted to: programmer_humor@programming.dev
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up10arrow-down1·1 day agoBalls.suck() is the correct syntax.
minus-squareRagingToad@feddit.nllinkfedilinkarrow-up4·1 day agoDon’t you need to declare new Balls() first? Or do you suck() Balls static?
minus-squarexigoi@lemmy.sdf.orglinkfedilinkEnglisharrow-up9·edit-212 hours agoBallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up7·edit-218 hours agoAll of this is okay, but it’s not production ready. This is what real production code looks like: SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up10·18 hours agoPython port: from ballsucker import suck suck()
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up3·1 day agoOr I didn’t using the correct naming convention!
minus-squareluciferofastora@lemmy.ziplinkfedilinkarrow-up2·12 hours agoActually, it would be OOP.suck(ddplf.getBalls())
Good, OOP can suck my balls
Balls.suck() is the correct syntax.
Don’t you need to declare new Balls() first? Or do you suck() Balls static?
BallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
All of this is okay, but it’s not production ready. This is what real production code looks like:
SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
Python port:
from ballsucker import suck suck()
Or I didn’t using the correct naming convention!
Actually, it would be
OOP.suck(ddplf.getBalls())